
Tutorial 5. Installing Applications and 
Creating a Workstation AMI 
 
Estimated Time to Complete: 1 hour, 30 minutes 

Review of: Tutorial 4: Building a Render Scheduler with AWS Thinkbox Deadline 
In the last tutorial we set up an instance to manage the renders that get sent to the render farm 
within our studio. We installed Firefox and AWS Thinkbox Deadline, as well as configured the 
Monitor. Finally, we tested our Deadline setup to make sure it was working. 

Overview of this Tutorial 
In this tutorial we’ll take you through preparing your 
Windows workstation and installing your applications, such as Deadline and Blender, as well as 
the creation of your Workstation Amazon Machine Image (AMI). This will allow you to create a 
custom template that you can use to launch additional workstations without having to set 
everything up each time.  
 

https://studio-in-the-cloud-tutorials.s3-us-west-1.amazonaws.com/tutorial-4/Tutorial+4+-+Building+a+Render+Scheduler+with+AWS+Thinkbox+Deadline.pdf


Startup Notes 
If you just finished the last tutorial, you already have your Render Scheduler instance running 
and can continue. However, if you stopped your Render Scheduler when finishing up the last 
tutorial, navigate to the EC2 dashboard and start it now. Once it’s running, make sure to login as 
Administrator and start up the Deadline Monitor, Deadline Remote Connection Server (RCS), 
and Deadline Pulse.  The Deadline Worker should start automatically after you login, but you 
should check that it’s running and launch manually if needed. 
 
Once you’ve done that you can continue onto the next step. 

Launching a New Instance from Your Launch Template 

• In the EC2 Dashboard navigate to your Launch 
Templates  

• Select your Management Launch Template (e.g., My-
Studio-Management-LT), click on the Actions menu 
and select Launch instance from template 

• Select the most recent version in Source template 
version 

• Leave number of instances at 1 

• In Instance Type, change it to a g4dn.4xlarge  Note: If 
you don’t see the g4dn.4xlarge available, you can use 
a g3.4xlarge instance instead. 

• In Storage (volumes) make sure you have enough 
space to install all the applications you need, we recommend 150 GiB if you have 
multiple applications you will be installing 

• In Instance Tags, change the Name value to Workstation_Win and click the 
checkboxes to tag the volumes as well.  

• You can leave the rest of the launch template at its defaults and click Launch 
instance from template 

o Note: If you are using a newly-created AWS account or have never launched 
a G4 or G3 instance before, you may see a warning message saying that you 
have requested more vCPUs than your current limit.  If that happens, please 
see the Appendix in Tutorial 1 for instructions on how to check your current 
quota value and request an increase to at least 16 vCPUs. 

• After the instance has launched, go to the list of running instances, right mouse click 
on the new instance and choose Networking → Change Security Groups 

• Add the Deadline security group (e.g., My-Studio-Deadline-SG) that you created in 
Tutorial 4.  You can find the name and ID of your Deadline security group in the cheat 
sheet. 

• Click Assign Security Groups 

 
 

https://studio-in-the-cloud-tutorials.s3-us-west-1.amazonaws.com/tutorial-1/Tutorial+1-+Getting+Started+with+AWS+Virtual+Workstations.pdf#page=20


 

Create S3 Get Object Privileges 
As you can see, we’re launching a Windows instance with a GPU - this will let us run powerful 3D 
applications. For those applications to run correctly, they will need the latest NVIDIA graphics 
drivers. In a step below we will download and install those drivers from an S3 bucket. In order to 
do this, we are going to need to give our instance permission to access them from S3. While 
waiting for your instance to start, you can enable these permissions. 

• Go to Services → IAM 

• Select Roles in the left panel 

• Search for EC2DomainJoin 

• Click on its name 

• Click Attach Policies 

• Search for S3 

• Click the checkbox next to AmazonS3ReadOnlyAccess 

 
 

• Select Attach Policy 

Log in to Your Workstation 

Log in as Administrator 
In order to install applications on your workstation instance, you should log in 
as Administrator just as you did in the last tutorial. Once logged in, you can begin the 
installation process for your applications. 

• To log into the Workstation_Win instance as Administrator: 

o Check that the instance is initialized with 2/2 checked passed 

o Select the instance and hit Connect 

o Click Download the Remote Desktop File 

o Open Remote Desktop 



o The username should already be set to Administrator. In Tutorial 3, we 
manually set the Administrator password to match your Active Directory 
Admin password, so you can just enter that here without having to click the 
Get Password button. You can also find your Active Directory Admin password 
under the Tutorial 2 section of the cheat sheet. 

Set Up Graphics Drivers 
Now it’s time to download the drivers mentioned above. As a reminder, it’s always important to 
make sure the drivers for your machines are up to date. The g4dn.4xlarge we are using has the 
NVIDIA T4 GPU, so let’s grab the latest drivers from NVIDIA.   
 
Note: If g4 instances are not available in your region and you launched a g3.4xlarge instead, 
there are some minor differences in the instructions below to get the proper drivers.  Don’t 
worry, we’ll call out any changes that you need to make. 
 
We’ll be using some PowerShell commands to download the drivers and the NIVIDIA GRID Cloud 
End User License Agreement to the desktop of your instance. 
 

• Open a PowerShell window. 

• Start by running one of the commands below, depending on the type of instance 
you launched above: 

o If you launched a g4dn.4xlarge instance: 

$KeyPrefix = "g4/latest" 

o If you launched a g3.4xlarge instance: 

$KeyPrefix = "latest" 

• Next, copy and paste the following commands to actually download the drivers that 
you need.  These commands are the same for both G4 and G3 instance. 

Commands – Note: <shift>+click on the image to open the text in a new tab. 

• The download will begin, showing you the status in the shell 

http://aws-nvidia-license-agreement.s3.amazonaws.com/NvidiaGridAWSUserLicenseAgreement.DOCX
http://aws-nvidia-license-agreement.s3.amazonaws.com/NvidiaGridAWSUserLicenseAgreement.DOCX
https://studio-in-the-cloud-tutorials.s3-us-west-1.amazonaws.com/tutorial-5/snippets/Set-up-graphics-drivers_download-drivers.txt


 
• Once it’s done, navigate to the desktop  

• Click on the folder called NVIDIA 

• Depending on the type of instance, you’ll navigate into a different folder next: 

o For a g4dn.4xlarge instance navigate  into g4/latest 

o For a g3.4xlarge instance, navigate into latest 

• Double click on the installer for Windows 10 (The file name will look something 
like 441.66_grid_win10_ 64bit_international_whql) 

 
 

• Click OK to start the installer. Note: Sometimes the installer window pops up behind 
the File Explorer window.   

• Click Agree and Continue (or Ok if you see that instead), then Next. 

• When you get to the end of the installation process, click on Close, then restart your 
instance.  (Or if the installer has a Restart Now button, you may click that to restart 
your instance.) 

• After waiting a minute or so for the instance to restart, Reconnect to your 
workstation and login as Administrator again. 

• To verify that your GPU is working properly, open the Start Menu, type Device 
Manager and then select Device Manager from the list 

o Click the > next to Display adapters 

o If you see NVIDIA Tesla T4 (or NVIDIA Tesla M60 if you’re using a g3.4xlarge 
instance) then you are all set. 



 
o Exit Device Manger. 

• Now, we will disable the licensing page in the control panel to prevent users from 
accidentally changing the product type (NVIDIA GRID Virtual Workstation is enabled 
by default). For more information, see the GRID Licensing User Guide. 

o Go to the Start Menu and type reg and select Registry Editor. 

o Navigate to HKEY_LOCAL_MACHINE → SOFTWARE → NVIDIA Corporation 
→ Global and then select GridLicensing. 

 

http://docs.nvidia.com/grid/4.6/grid-licensing-user-guide/index.html


o Right-click on the right pane and choose New, DWORD (32-bit) Value. 

 
 

o For Name, enter NvCplDisableManageLicensePage and hit Enter. 

o Right-click on NvCplDisableManageLicensePage and choose Modify. 

 

 

o For Value data, type 1 and choose OK. 

 
 



Set Up Application Installers 
Setting up your applications to install onto your instance is as simple as downloading the 
installer for an application as you would regularly on a physical workstation. For the purpose of 
this setup we’re going to stick with Blender 2.8, a powerful open source 3D content creation 
application, since it is free and does not require licensing.  

Connect to the Studio FSx Drive 
Since we’ve already created an FSx Drive that has a location for installers to be stored, we can 
connect to it with this workstation using the same steps we did in Tutorial 3. 

• Open a File Explorer window. 

• From the navigation pane, right-click on This PC and choose Map Network Drive... 

• Choose a drive letter of your choice for Drive (e.g., Z:). 

• Enter the full CNAME Alias for your file share that you noted above for Folder.  

o e.g., \\studio.mystudio.com\share\ 

o Click Finish. 

• Use your Active Directory Admin login credentials. For example: 

o Username: Admin 

o Password: Your Admin Password 

Install Firefox 
We are going to use Firefox as our browser on our workstations and because the installer is 
already saved onto the FSx Drive, it can be easily accessed.  

• Navigate to Z:\installers\firefox  

• Run the installer from that location.  

o Note: We already installed Firefox on the User Manager instance, but we 
haven’t installed it yet on this machine. That’s why we’re going through the 
process again. This will be the last time we need to install Firefox on one of 
our instances because we will be saving this as an AMI (Amazon Machine 
Image). 

Install Blender 

• Open up Firefox and navigate to https://www.blender.org 

• Click Download in the menu bar at the top and then Download Blender 2.81a (or 
whatever the latest version is). 

o Download the 64-bit Windows installer and the Linux installer. You’ll need 
both! 

• Create a blender folder in Z:\installers. 

• Once the download is complete navigate to your Downloads folder. 

• Move the installers to Z:\installers\blender. 

https://www.blender.org/


• Launch the Windows installer. 

• Follow the on screen prompts, accept the license agreement and leave everything 
else at the default settings. 

Blender is now installed on your instance! 

Copy Blender Shortcut to the Z: Drive 
When you installed Blender, it created a shortcut on the desktop. Unfortunately, this shortcut 
doesn’t carry over when other users (mystudio\Admin, mystudio\jason) login to the machine. 
But we can fix that by copying the shortcut to the Z: drive. 

• Open File Explorer and create a new folder named applications in the Z: drive 
(Z:\applications). 

• Click drag the Blender shortcut from the desktop to Z:\applications. 

• Now any user who logs in can run Blender by double-clicking on 
Z:\applications\blender . 

Additional Applications 

• There are two additional applications we would recommend installing, DJV and 
Krita. 

o DJV (http://djv.sourceforge.net/)  - Professional media review software for 
VFX, animation, and film production. 

o Krita (https://krita.org/) - Professional open source painting program. 

• For each of these, we recommend creating a folder inside Z:\installers (e.g., 
Z:\installers\krita, Z:\installers\djv), downloading the installer files from the 
appropriate websites, and copying them to the installers location. Only the Windows 
version is needed for these. Then, install the applications directly on the instance 
just like you did with Blender. 

Install AWS Thinkbox Deadline Client 
We need to install the Deadline Client on our workstation in order to have access to Deadline 
Monitor and to connect to the Render Scheduler. 

• Go to Z:\installers\thinkbox . 

• Double click on Deadline-10.1.1.13-windows-installers folder (your version may be 
different). 

• Double click on the DeadlineClient installer. 

• Click Run. 

• Click Next. 

• Accept the license agreement. 

• Leave the Installation Directory as Default. 

• Leave OFF the Remote Connection Server and click Next. 

http://djv.sourceforge.net/
https://krita.org/


o Note: We are leaving this off because the Render Scheduler is the one that 
needs the Deadline Remote Connection Server (RCS) installed. This is simply 
a client, so there is no need for the scheduler to be installed here. 

• Set Connection Type to Remote Server and click Next 

o Note: Because we will be connecting to another instance, we must set the 
Connection Type to Remote Server. 

• Put the Private IP address of the Render Scheduler machine into Server Address, and 
point it at port 4433. 

o You should have already written down the Private IP for your render scheduler 
on the cheat sheet during Tutorial 4. It should look something like 
(10.0.0.219). 

o Enter the private IP with a port number of 4433 into the server address field 
(e.g., 10.0.0.219:4433). 

o Note: This is important, because the default port is 8080 and that won’t 
work. 

 
 

• Click Next 

• Set the Client 
Certificate to Z:\app_env\thinkbox\DeadlineCertificates\Deadline10RemoteClient.p
fx . 

o Note: Make sure you select the Deadline10RemoteClient.pfx file and not the 
Deadline10Client.pfx file, which is also in the same folder.  You might have 
to enter this path manually if the UI won’t let you select the Z: drive. 

• Leave the Certificate Password blank and click Next. 

• Set License Mode to Usage Based and click Next. 

• Uncheck Launch Worker When Launcher Starts and click Next. 

o Note: We are turning this off because we are currently setting up one of our 
workstation machines. We don’t want render workers to launch on these 
instances. 

• Click Next  again to finish the install 

o Note: you may get an error that says “An error occurred when trying to set 
the repository connection settings". That’s okay, we’ll fix it later. 



Connect to the Deadline Repository 

• In the start menu go to Thinkbox → Deadline Monitor 

• If you get an error saying it can’t connect to the Repository make sure you have 
these options selected in the prompt (note: your IP address will be different. Make 
sure you have the correct port selected) 

 
 

• If it still doesn’t work, double-check that your Render Scheduler instance is running, 
you’re logged in as Administrator, and Deadline Monitor, Deadline RCS, and 
Deadline Pulse are all running. 

• If it works correctly, you will be able to connect to the Deadline Monitor. 

Install Deadline Blender Submitter 
In preparation for working with your render farm, we recommend you install the Deadline 
Submitter add-on inside of Blender.  

• Run Blender. 

• Go Edit → Preferences... (or File→Preferences - for Blender 2.79 & earlier). 

• Click on Add-Ons in the left panel. 

• Click Install... 

• Navigate to Z:\installers\thinkbox\submission\Blender\Client 

o Note: We copied the submissions folder to Z:\installers\thinkbox in Tutorial 
4.  If you don’t see it there, please refer back to the instructions in that 
section. 

• Choose DeadlineBlenderClient.py . 

• Click Install Add-on. 

• Click the checkbox next to Render: Submit Blender to Deadline add-on. 

https://studio-in-the-cloud-tutorials.s3-us-west-1.amazonaws.com/tutorial-4/Tutorial+4+-+Building+a+Render+Scheduler+with+AWS+Thinkbox+Deadline.pdf#page=13
https://studio-in-the-cloud-tutorials.s3-us-west-1.amazonaws.com/tutorial-4/Tutorial+4+-+Building+a+Render+Scheduler+with+AWS+Thinkbox+Deadline.pdf#page=13


 
 

• Close your preferences window. 

Test Submitting to Deadline 

• Open the Deadline Monitor and check that there is a single worker in the list of 
workers at the bottom of the window with a status of “Idle”.  This is the worker 
running on your Render Scheduler.  If you don’t see a worker listed or its status is 
“Offline”, please login to your Render Scheduler and launch the Deadline Worker 
before continuing. 

• Back in Blender, save your current scene (this is a requirement to submit to 
deadline). 

• Choose Render→Submit To Deadline. 

• The Submit Blender Job To Deadline window will pop up. 

• Leave the Group set to none. Note: We won’t be using the “linux_worker” group until 
the next tutorial. 

• Change the Output File path to a location of your choosing. 

• Change the Frame list from 1-250 to 1. 

• Hit Submit and then close the submit window 

o Note: You’ll get warnings if either your Blender file or your output file are 
set to the C: drive of the instance, but don’t worry, for this test that’s fine. 
You can just click on Yes in any popups you see. 

• Open the Deadline Monitor. 

• Your job will be sitting in the job queue. 

• Don’t worry if the job fails or cycles between “Queued” “Waiting to Start” and 
“Rendering”.  We are going to set up workers in the next tutorial that can 
successfully render jobs for you. 

• The goal of this exercise is just to make sure that your workstation can connect to 
the Render Scheduler.  As long as your job appears in the job queue in the Deadline 
Monitor, then you are good to go. 



Creating an Amazon Machine Image 
Now that you’ve installed your applications and set up the graphics drivers, you’ll want to make 
sure you can launch another workstation just like this one but without all the hassle of setting it 
up again. Luckily, we’ve already done something similar in Tutorial 3 when we set up the launch 
template.  
 
What we’re going to be doing this time is creating an AMI (Amazon Machine Image) by making 
an image of the machine you are using that includes all the applications you’ve installed and 
updates you’ve completed on the instance, and allow you to create as many copies of that 
instance as you need for your studio.  

Preparing Your Instance 

• Close Blender and the Deadline Monitor 

• Disconnect from your FSx Drive (Z:). 

o Open the File Explorer. 

o Under This PC on the left, click on the Z: drive with the Right Mouse 
Button and choose Disconnect. 

 
 

• Go to the start menu, type Ec2LaunchSettings and launch it. 

• Make sure Set Computer Name is selected. 

https://studio-in-the-cloud-tutorials.s3-us-west-1.amazonaws.com/tutorial-3/Tutorial+3+-+Setting+Up+an+FSx+File+System+and+User+Accounts.pdf#page=39


o This will ensure each instance you create has a unique name. 

• Check that Administrator Password is set to Specify and input the Administrator 
Password for your Active Directory (e.g. password for mystudio\Admin). 

• Select Run EC2Launch on every boot. 

• Click Shutdown with Sysprep. 

 
 

• Click Yes. 

• This will shutdown your instance after a few processes run. It can take a few 
minutes, so feel free to grab a coffee (or tea). 



Create Workstation AMI 

• Navigate back to the EC2 Dashboard and find the Workstation that has just been 
shut down, if it is not completely stopped yet, wait for that process to finish 

 
 

• Right-click on the instance and choose Image → Create Image 

• Give it an appropriate name (e.g., My-Studio-Workstation-AMI). Please also enter the 
AMI name in your cheat sheet. 

• Give your workstation AMI a description if you want. 

• Increase its storage if necessary. 

 
 

• Click Create Image. 

• AMI creation can also take 5 to 10 minutes to complete. How about more coffee? 

o To see if your AMI is ready click on AMIs in the left panel. The AMI will need 
to finish creating before you can create a Launch Template with it. 

o While you’re waiting, you can also add Tags to your AMI. Again, we 
recommend creating at least a Studio tag and Name tag. 

o Now is a good time to note the AMI ID in the cheat sheet. You can find the ID 
by selecting the AMI from the list and looking at the top left of the Details tab. 

Create Workstation Launch Template 
Now that you have an AMI for your workstation, you can create a launch template that will make 
it really easy to spin up new workstations when you want to collaborate with other artists. 



• Once your new AMI is listed as available, go to Services → EC2 and click on Running 
Instances. 

• Right mouse click on your Workstation instance and choose Create Template From 
Instance. 

• Name your launch template (e.g., My-Studio-Workstation-LT). Write down the name 
on your cheat sheet. 

• Give it a description if you want. 

 
 

• You will need to change the AMI ID to point to the one that you just created. 

o In the AMI dropdown, scroll down to the My AMIs section and then select 
the Workstation AMI (e.g., My-Studio-Workstation-AMI) that you just 
made. If necessary, refer to the Workstation AMI ID on your cheat sheet. 

 
 



• Under Network interfaces, set Auto-assign public IP to Enable, otherwise you will 
not be able to connect to the instances you launch. 

• Also under Network interfaces, check that the Security Group IDs for both 
your Deadline Security Group (e.g., My-Studio-Deadline-SG) and your Remote 
Desktop Security Group (e.g., My-Studio-Remote-Desktop-SG) are listed. You can 
find the IDs for both of those security groups on your cheat sheet. 

o Click Show all selected to view the IDs for the currently selected security 
groups. 

o If either security group is missing, click the drop down menu and select the 
missing group. 

 
 

• Click Create launch template. 

Launch a New Workstation 
Now let’s test the launch template! 

• Go to Services → EC2 and click on Launch Templates in the left panel. 

• Select your Workstation launch template (e.g., My-Studio-Workstation-LT). Refer to 
your cheat sheet, if needed. 

• Choose Actions → Launch instance from template. 

• Select the version (if this is your first time running through the tutorial you’ll select 
version 1). 



• Scroll down to the bottom and click Launch instance from template. 

• Go back to Services → EC2, click on Running instances. 

• When your new instance is done initializing you can log into the instance with your 
Active Directory username (e.g., mystudio\jason) and password. Note: it may take 
about 10 minutes for this instance to be available. 

o If you are having trouble connecting, please wait a few more minutes. If the 
instance still isn’t connecting after 15 minutes, try rebooting the instance to 
kick-start it. 

• Note #1: If you do not see the shortcut to launch Blender on the desktop…don’t 
worry, it is still installed.  The desktop shortcut we used earlier was created when you 
logged in as Administrator, so it doesn’t exist for the current Active Directory user.  
Instead, you can use the shortcut that we copied to the Z: drive above.  It should be 
located in Z:\applications. 

• Note #2: Similar to the shortcut, since you originally installed the Deadline Blender 
submitter as Administrator, you will need to install it again for the current Active 
Directory user.  Please follow the directions from earlier in this tutorial to install the 
submitter. 

• Once you confirm that your new Workstation_Win instance is running correctly, feel 
free to terminate the old Workstation_Win instance that you setup at the beginning 
of this tutorial. It should currently be listed as stopped in the instance list. 



Your VPC So Far 

 
 
In this tutorial, you added a new virtual workstation instance and installed applications on your 
workstation and your shared storage. You also created a new workstation AMI and launch 
template that you can use to easily launch new workstations for your artists. 

Shut Down Notes 
If you are going to continue to the next tutorial then leave your Workstation and Render 
Scheduler instances running, but if you are going to continue another time then you can stop 
them both and restart them when you start the next tutorial. 
 
Link to next tutorial: Tutorial 6: Setting Up a Linux Farm Worker and Spot Fleet Request 

 

https://studio-in-the-cloud-tutorials.s3-us-west-1.amazonaws.com/tutorial-6/Tutorial+6+-+Setting+Up+a+Linux+Farm+Worker+and+Spot+Fleet+Request.pdf


Appendix 

Tutorial Table of Contents 
 
Tutorial 1: Getting Started with AWS Virtual Workstations  
Tutorial 2: Creating a VPC and Active Directory for Your Studio 
Tutorial 3: Setting Up an FSx File System and User Accounts 
Tutorial 4: Building a Render Scheduler with AWS Thinkbox Deadline 
Tutorial 5: Installing Applications and Creating a Workstation AMI – this page 
Tutorial 6: Setting Up a Linux Farm Worker and Spot Fleet Request 
Tutorial 7: Onboarding New Artists and Sample Workflow 

Links to AWS Documentation 

• NVIDIA GRID Drivers for G3 and G4 Instances 

Downloads 

• Important Information Cheat Sheet 

 

https://studio-in-the-cloud-tutorials.s3-us-west-1.amazonaws.com/tutorial-1/Tutorial+1-+Getting+Started+with+AWS+Virtual+Workstations.pdf
https://studio-in-the-cloud-tutorials.s3-us-west-1.amazonaws.com/tutorial-2/Tutorial+2+-+Creating+a+VPC+and+Active+Directory+for+Your+Studio.pdf
https://studio-in-the-cloud-tutorials.s3-us-west-1.amazonaws.com/tutorial-3/Tutorial+3+-+Setting+Up+an+FSx+File+System+and+User+Accounts.pdf
https://studio-in-the-cloud-tutorials.s3-us-west-1.amazonaws.com/tutorial-4/Tutorial+4+-+Building+a+Render+Scheduler+with+AWS+Thinkbox+Deadline.pdf
https://studio-in-the-cloud-tutorials.s3-us-west-1.amazonaws.com/tutorial-6/Tutorial+6+-+Setting+Up+a+Linux+Farm+Worker+and+Spot+Fleet+Request.pdf
https://studio-in-the-cloud-tutorials.s3-us-west-1.amazonaws.com/tutorial-7/Tutorial+7+-+Onboarding+New+Artists+and+Sample+Workflow.pdf
https://docs.aws.amazon.com/AWSEC2/latest/WindowsGuide/install-nvidia-driver.html#nvidia-GRID-driver
https://studio-in-the-cloud-tutorials.s3-us-west-1.amazonaws.com/tutorial-1/Important-Information-Cheat-Sheet.pdf
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