
Tutorial 7. Onboarding New Artists and 
Sample Workflow 
 
Estimated Time to Complete: 25 minutes 

Review of: Tutorial 6: Setting Up a Linux Farm Worker and Spot Fleet Request 
 
In the previous tutorial, you built your own cloud 
render farm by setting up a Linux instance with all 
the necessary software for rendering. Then you 
created a launch template that could be used by 
AWS Thinkbox Deadline to automatically launch 
Farm Workers using that template when a render is 
submitted. With that, you now have all the 
necessary infrastructure in place for your Studio in 
the Cloud. Give yourself a pat on the back because 
now you can move on to creating your content. 

Overview 
In this tutorial, we’ll walk through how you and 
your artists will actually use your Studio in the 
Cloud on a day-to-day basis. We’ll start with a 
quick review of your basic infrastructure and then 
cover the process for onboarding a new 
artist. Finally, we'll step through a sample 
workflow that an artist would follow to animate 
and render a shot with Blender. 

Startup Notes 
If you’re coming straight from the last tutorial and already have your Render Scheduler instance 
running, then you can continue straight to the next section, Review Your 
Infrastructure. Otherwise, please go to the EC2 Dashboard to start it up again. Remember 
to start up the Deadline Monitor, Deadline RCS (Remote Connection Server), and Deadline 
Pulse as well. 
 
Note: We also had you stop your User Management instance at the end of the last tutorial. If you 
have already added accounts for all of your artists, you can leave that “stopped” for now.  

Review Your Infrastructure 
Let’s quickly review (and marvel at) all that you have created over the course of these tutorials.   

https://studio-in-the-cloud-tutorials.s3-us-west-1.amazonaws.com/tutorial-6/Tutorial+6+-+Setting+Up+a+Linux+Farm+Worker+and+Spot+Fleet+Request.pdf


• Your VPC - a private network in the cloud that contains all of the pieces for your studio. 

• User Management instance - you used this to help set up your studio and add accounts 
for your artists. At the moment, that instance is stopped, but can be restarted at anytime 
to add more artists. 

• FSx - fast cloud storage for your user profile, studio tools, content creation applications 
and production data 

• Render Scheduler instance - uses Deadline to manage the renders that your artists 
submit to the farm. Once production begins, this instance should remain running 
constantly so that it is always available for artist submissions. 

• Windows Workstation instances - the GPU-enabled instances your artists will be using to 
create content, connected to FSx to retrieve and store production data. At the moment, 
you may not have any of these running, but you will add them one-by-one as you add 
artists. 

• Linux Farm Worker instances - the instances that will be launched automatically 
whenever a render is submitted, connected to FSx to retrieve production data. These 
instances will be started and stopped on demand, so the number of running instances 
will vary and when there are no renders, there will be no running instances. 

 
When combined, all the above services and different types of virtual workstations allow you to 
move your content creation to the cloud.  Now that you have all the pieces in place, it’s time to 
start thinking about your next steps before entering into production.  Below we’ll cover 
additional steps to complete before onboarding your artists. 
 

⚠ Note: As we mentioned at the beginning of Tutorial 1, the security measures we have 
implemented so far are sufficient for initial setup and testing of a cloud-based production 
pipeline.  However, before using your setup for production content that may require a higher 
level of security, we recommend adding extra measures, according to your individual security 
compliance goals.  While that is beyond the scope of these first tutorials, in the future we will 
publish an add-on tutorial focused specifically on how to add extra layers of security to your 
Studio in the Cloud. 

Set Up Your Project’s Directory Structure 
Before beginning work on your cloud-based project, you should create a basic directory structure 
on your FSx file system to share your production data separate from your tools, profiles, 
installers and applications. Every studio and project is different, so create a structure that works 
for you. We suggest creating a top-level directory for your projects and then individual project 
directories and sub-directories for production shots, a library of assets, etc. 

• Connect to your Render Scheduler instance or another instance that is already 
connected to your FSx file system. 

• Open File Explorer and click on This PC, then double-click on your studio drive (e.g., Z:). 

• Right-click and select New→Folder, then create a folder named projects. This will keep 
all the data for your projects separate from your user profiles and studio tools. 



• Double-click on the project folder. 

• Right-click and select New→Folder, then create a folder named for your project and 
repeat to create any sub-folders that you need (e.g. library, production, etc.). 

Onboarding a New Artist 
Once they are set up, your storage, Render Scheduler, and Farm Workers should run inside your 
VPC with little to no supervision. So the only thing you should need to worry about when adding 
a new artist is launching a new Windows Workstation for them to use. 
 
To keep things simple, we’re going to assume that you, as the administrator of your studio, will 
be responsible for starting and stopping Windows Workstations as they are needed. It is possible 
to allow individual artists to start and stop their own instances by granting them access to the 
AWS Console. However, doing so requires that you add them as users on your AWS account 
(separate from their user accounts on your studio).  It also means tightly controlling their access 
to AWS services so they don’t accidentally delete your FSx file system, etc. Ultimately the choice 
depends on your comfort level as well as how technical your artists are. 
 
Note: Before launching additional Windows Workstations you may need to request a quota 
increase to your On-Demand G instances limit. Each of the g4dn.4xlarge or g3.4xlarge instances 
we use in these tutorials requires 16 vCPUs of quota. Please see the Appendix in Tutorial 1 for 
instructions on how to view your current quota and request an increase. 

Launch a New Windows Workstation 

• Go to Services → EC2 and click on Launch Templates in the left panel. 

• Select the Windows Workstation launch template that you made in Tutorial 5 (e.g., My-
Studio-Workstation-LT). Please see the cheat sheet if needed for the name of your 
workstation launch template. 

• Choose Actions → Launch instance from template. 

• Select the version. 

• Scroll down to Instance tags and add the name of the user to the end of the Name tag 
(e.g., Workstation - jason). 

• Choose Launch instance from template. 

• Click Close. 

Send Workstation Login Information to Your Artist 
In order for your artist to connect to their new virtual workstation, you will need to send them 
some login information. 

• Select Instances in the left panel 

• When your new workstation instance is done initializing, select it and make note of 
the IPv4 Public IP on the Description tab at the bottom of the page. 

• You will need to send the following information to your new artist: 

https://studio-in-the-cloud-tutorials.s3-us-west-1.amazonaws.com/tutorial-1/Tutorial+1-+Getting+Started+with+AWS+Virtual+Workstations.pdf#page=20


o IP address of their workstation 

o username 

o password 

o your Active Directory’s NetBios name (e.g., mystudio), they will need this to 
login. Please refer to the Tutorial 2 section of the cheat sheet for your active 
directory’s NetBios name. 

o A reminder to change their password after they have logged in for the first time 

o A brief explanation of the directory structure that you set up for your project so 
they will know how and where to store their data 

Workstation Setup - Artist Instructions 

How to Connect to Your Windows Virtual Workstation 

• Download and install Remote Desktop for Windows, macOS or Linux. 

• Launch Remote Desktop. 

• In the Computer field, enter the IP address provided by your administrator. 

• Click the down arrow next to Show options. 

• For User name enter the Active Directory NetBios name and username provided by your 
administrator, with a “\” in between, like this <Active Directory NetBios 
name>\<username> (e.g., mystudio\jason). 

• Click Connect. 

• In the popup window enter the password provided by your administrator then click OK. 

• When a window pops up that says The identity of the remote computer cannot be 
verified click Yes to continue connecting. 

• Finally, a new window will open that shows the desktop of your cloud workstation. 

Change Your Password 

• In your Remote Desktop session, hit <ctrl>+<alt>+<end>. 

• Next click Change a password. 

• Type in your old password and then your new one and hit <enter>. 

Sample Workflow 

Creating Content with Blender 

• Blender is already installed on your workstation instance. You can launch it using a 
shortcut located here: Z:\applications\blender . 

• Create your content in Blender, being sure to save your work to the appropriate folder 
on the Z: drive and not to the C: drive of your workstation. 

https://www.microsoft.com/en-us/p/microsoft-remote-desktop/9wzdncrfj3ps
https://apps.apple.com/us/app/microsoft-remote-desktop-10/id1295203466?mt=12
http://www.rdesktop.org/


• You will need to install the Deadline Blender submitter before submitting: 

o Run Blender. 

o Go Edit → Preferences... (or File→Preferences - for Blender 2.79 & earlier). 

o Click on Add-Ons in the left panel. 

o Click Install... 

o Navigate to Z:\installers\thinkbox\submission\Blender\Client . 

o Choose DeadlineBlenderClient.py . 

o Click Install Add-on. 

o Click the checkbox next to Render: Submit Blender to Deadline add-on. 

 
 

o Close your preferences window. 

• When you are ready, submit a render to the farm by selecting Render→Submit To 
Deadline. 

• Set the Group to linux_worker. 

• Set the Frame List to your frame range. 

• Make sure the Blender File and Output File is set properly. 

• Click Submit. 

Maintaining Your Studio 
Once you’ve completed these tutorials, there is a minimum amount of AWS services that you will 
need to leave running in order to continue to use your Studio in the Cloud. There are other 
services that can be stopped and started as needed.  Let’s go through each one: 

• Render Scheduler instance 

o In order to submit renders to your Linux worker farm, your Render Scheduler 
instance will need to be running. 

o If you anticipate needing to render at any time of day you can leave it running 
constantly, but be aware that you will be charged for every hour it is running, 
regardless of whether there are any active render jobs. 

o You can conserve money by starting and stopping the Render Scheduler as 
needed, but be aware that every time you restart it, you will need to login and 



make sure that the Deadline Monitor, Deadline RCS, and Deadline Pulse are 
running. 

• Active Directory 

o This allows your users to login to your instances. 

o There is nothing you need to do to maintain this service.  But it also cannot be 
stopped and started like an instance. 

o You will need to keep your Active Directory for as long as your studio is active. It 
will keep running until you actively delete it. 

• FSx File System 

o This is your shared storage for your studio and it must be available for as long as 
your studio is running. 

o Like Active Directory, you cannot stop and start FSx. As long as you leave it 
active, you should be good to go. 

• User Management instance 

o You should have already stopped this instance during the course of the tutorials. 

o You can leave this instance in a stopped state until you need to add new artists. 
At that point, you can start the instance, add your new artists and then stop it 
when you’re done to conserve resources. 

• Windows Workstation instances 

o If you don’t currently have any artists working, you can stop all your Windows 
Workstation instances. 

o You can launch new Window Workstations at any time by using your workstation 
launch template (e.g., My-Studio-Workstation-LT). 

o Make sure to stop your Windows Workstation instances when you artists are not 
using them to reduce costs. Since they only need to be running when an artist is 
actively using them, there is not reason to leave them running all the time. 

Shut Down Notes 
If at any point you are finished with your Studio in the Cloud and would like to shut down all the 
services associated with it, please see the instructions in the Appendix below: Shutting It All 
Down. 

Thank you! 
We appreciate your time spent reading and following the steps in these tutorials. We hope that 
this has given you a taste of how to use the scale, power and convenience of AWS to move your 
studio to the cloud. Happy creating! 

 



Appendix 

Tutorial Table of Contents 
 
Tutorial 1: Getting Started with AWS Virtual Workstations  
Tutorial 2: Creating a VPC and Active Directory for Your Studio 
Tutorial 3: Setting Up an FSx File System and User Accounts 
Tutorial 4: Building a Render Scheduler with AWS Thinkbox Deadline 
Tutorial 5: Installing Applications and Creating a Workstation AMI 
Tutorial 6: Setting Up a Linux Farm Worker and Spot Fleet Request 
Tutorial 7: Onboarding New Artists and Sample Workflow – this page 

Downloads 

• Important Information Cheat Sheet 

Shutting It All Down 
 
Once you have seen how to set up your studio in the cloud, it’s important to know how to shut it 
down. The following are the steps you can take to shut everything down. 

Terminate All Running Instances 

• Go to the EC2 Console and click on the Instances. 

• Select all running and stopped instances and choose Actions → Instance State → 
Terminate. 

• When the window pops up with the warning, confirming to shut down instances, make 
sure to also Release the Elastic IP associated with the Render Scheduler. 

• Click Yes, Terminate. 

Delete Launch Templates 

• Click on Launch Templates 

• One at a time, select each Launch Template and choose Actions → Delete Template 

o Confirm deleting by typing Delete in the field. 

o Click Delete 

Check that All Spot Requests are Canceled 

• Click on Spot Requests. 

• Make sure all spot requests have been cancelled. 

• If they haven’t, select the spot requests and choose Actions → Cancel Spot Request. 

Deregister All AMIs 

• Make sure to wait until all instances have been terminated. 

https://studio-in-the-cloud-tutorials.s3-us-west-1.amazonaws.com/tutorial-1/Tutorial+1-+Getting+Started+with+AWS+Virtual+Workstations.pdf
https://studio-in-the-cloud-tutorials.s3-us-west-1.amazonaws.com/tutorial-2/Tutorial+2+-+Creating+a+VPC+and+Active+Directory+for+Your+Studio.pdf
https://studio-in-the-cloud-tutorials.s3-us-west-1.amazonaws.com/tutorial-3/Tutorial+3+-+Setting+Up+an+FSx+File+System+and+User+Accounts.pdf
https://studio-in-the-cloud-tutorials.s3-us-west-1.amazonaws.com/tutorial-4/Tutorial+4+-+Building+a+Render+Scheduler+with+AWS+Thinkbox+Deadline.pdf
https://studio-in-the-cloud-tutorials.s3-us-west-1.amazonaws.com/tutorial-5/Tutorial+5+-+Installing+Applications+and+Creating+a+Workstation+AMI.pdf
https://studio-in-the-cloud-tutorials.s3-us-west-1.amazonaws.com/tutorial-6/Tutorial+6+-+Setting+Up+a+Linux+Farm+Worker+and+Spot+Fleet+Request.pdf
https://studio-in-the-cloud-tutorials.s3-us-west-1.amazonaws.com/tutorial-1/Important-Information-Cheat-Sheet.pdf


• Click on AMIs. 

• Select all AMIs associated with your studio. Choose Actions → Deregister. 

• Choose Continue. 

Delete FSx File System 

• Choose Services → FSx. 

• Select the studio drive. 

• Choose Actions → Delete File System. 

• In the popup window, you can choose to create a final backup, or not if you don’t care 
about keeping any of the data. 

• Then type the name of your drive in the field (e.g., fs-04af6ed309bc0d5a1). 

• Click Delete file system. 

• Note: It will take a few minutes for the file system to delete. 

Delete Active Directory 

• Make sure to wait until the FSx file system has been deleted. 

• Choose Services → Directory Service. 

• Select your Active Directory. 

• Choose Actions → Delete directory. 

• In the popup window, enter the directory name  (e.g., mystudio.com). 

• Click Delete. 

• Note: It will take a few minutes for the directory to delete. 

Delete the VPC 
 
It’s time to delete the VPC. This will automatically take down all other associated objects 
(Subnets, Security groups, etc) as well. 

• Choose Services → VPC. 

• Select your Studio VPC. 

• Choose Actions → Delete VPC. 

• Click Delete VPC. 

Delete the DHCP Option Set 

• Select DHCP Option Sets. 

• Select the studio DHCP Option Set. 

• Choose Actions → Delete DHCP Option Set. 



• Click Delete DHCP option set. 

Delete the Secret 

• Choose Services → Secrets Manager. 

• Click Secrets. 

• Select your secret (e.g., Admin/DomainJoin). 

• Choose Actions → Delete Secret. 

• Change the waiting period to 7 days. 

• Click Schedule Deletion. 
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