
Tutorial 9: Add-On - Using a Linux Instance 
for a Render Scheduler 
 
Estimated Time to Complete: 1 hour 

Review of Studio in the Cloud for Digital Content Creation  
In our previous 7-part getting started series of tutorials we provided step-by-step instructions 
for setting up your own fully cloud-based studio for digital content creation. Those tutorials 
covered a basic setup of virtual workstations, cloud storage and cloud rendering, however there 
are many ways to expand and customize your studio to meet your production needs. 

Linux vs. Windows Render Scheduler 
The Render Scheduler instance that you set up in the previous tutorials will be running for most 
of the life of your studio, so it makes sense to figure out how to control the cost of that instance 
as much as possible. One way to do that is to use a Linux instance instead of Windows as they 
tend to be cheaper - often saving as much as 50%. 
 
Setting up your Render Scheduler as a Linux instance is very similar to how you set up your 
Windows-based Render Scheduler - with the main difference being that you cannot connect to a 
Linux instance with Remote Desktop. Instead, we’re going to take advantage of Amazon’s NICE 
DCV - a high performance desktop and application streaming protocol. Not only will it handle 
both Windows and Linux instances, but it also has a raft of other great features, including: 

• Multi-screen support — Lets you expand the session desktop across up to four monitors.  

• Collaboration — Provides dynamic sessions that support multiple collaborative clients. 
Clients can connect and disconnect at any time during the session.  

• Support for USB, smart card, and stylus remotization (Windows / Linux Only)— Lets you 
use your peripherals in a NICE DCV session just like you would on your local computer. 

• GPU sharing (Linux NICE DCV servers only) — Lets you share one or more physical GPUs 
between multiple virtual sessions running on a Linux NICE DCV server.  

• Lossless quality video compression — Supports lossless quality video compression when 
the network and processor conditions allow.  

• No cost solution — There is no additional cost for using NICE DCV on AWS, you only pay 
the normal cost of the EC2 Linux instance. 

Overview of this Tutorial 
This tutorial will teach you how to launch a Linux instance, connect to it via DCV, install a new 
Deadline Repository and update your workers and workstations to connect to it. 



Prerequisites 

Complete the Previous Tutorials 
This tutorial is based off the Studio in the Cloud for Digital Content Creation tutorial series. If 
you haven’t completed that series, we highly recommend you do, as we will be utilizing much of 
the architecture we have already created.  You can find the first tutorial here: Tutorial 1: Getting 
Started with AWS Virtual Workstations  

Download the DCV client 
In order to connect to your Linux instance with DCV, you will need to download the DCV client 
software to your local computer.  You can find download links for Windows, Linux and MacOS 
here: NICE DCV Clients.  Click on the OS that you want to use to go to specific download and 
installation instructions. 

Using AWS Marketplace AMIs 
Instead of installing the NICE DCV software from scratch on a basic Linux instance, we’re going 
to start with an Amazon Machine Image (AMI) from the AWS Marketplace.  To review, an AMI 
contains a specific configuration of operating system and other software for your instance.  In 
past tutorials we created AMIs for specific instance types in your studio, such as User 
Management and Windows Workstations. 
 
The AWS Marketplace hosts thousands of AMIs that have already been created with specific 
software installed.  Using one of these AMIs can save you the time and hassle of installing and 
configuring software on your own.  In this case, we’re going to start with a Marketplace AMI that 
already has the NICE DCV Server installed. 
 
Before you can launch a Linux instance using that Marketplace AMI, you’ll need to add some 
extra permissions to your user. 

Add Marketplace Permissions to Your User 

• Go to Services→Security, Identity, & Compliance→IAM 

• In the navigation panel on the left, select Users 

• Click on the user for your account 

• Click the Add Permissions button 

• Click Attach existing policies directly 

https://studio-in-the-cloud-tutorials.s3-us-west-1.amazonaws.com/tutorial-1/Tutorial+1-+Getting+Started+with+AWS+Virtual+Workstations.pdf
https://studio-in-the-cloud-tutorials.s3-us-west-1.amazonaws.com/tutorial-1/Tutorial+1-+Getting+Started+with+AWS+Virtual+Workstations.pdf
https://docs.aws.amazon.com/dcv/latest/userguide/client.html


 

• Search for AWSMarketplace 

• Click the checkbox next to AWSMarketplaceManageSubscriptions 

 

• Click Next:Review 

• Click Add permissions 

Connect to a Linux Instance with DCV 
Now that you have permissions to access the DCV Marketplace AMI, we’re going to launch a 
Linux instance and make sure we can connect to it via the DCV client. 

Launch an EC2 Instance 

• Go to Services→ EC2 and click on Running Instances to see a list of your running 
instances 

• Click Launch Instance 

• Type Nice DCV in the search bar where you’re choosing your Amazon Machine Image 

• Click on AWS Marketplace to list only instances that exist in the AWS Marketplace 

• Click Select next to NICE DCV for Amazon Linux  



 
 

o A pricing list for the various instance types will come up, showing you what the 
costs will be 

o Click Continue 

• Choose an m5.xlarge instance type. If this isn’t powerful enough, you can always 
increase it later 

• Click Next: Configure Instance Details 

o Set the Network to your VPC (e.g., My-Studio-VPC) 

o Set the Subnet to Public Subnet A 

o Set Auto-Assign IP to Enable 

 
 

o Set your IAM Role to EC2DomainJoin 

 
 

• Click Next: Add Storage 

o Set your Volume Size to 100 (GiB) 



 

 

o Click Next: Add Tags 

• Click Next: Add Tags and then add tags for Studio and Name 

o Set Studio to My-Studio 

o Set Name to Render Scheduler - Linux 

• Click Next: Configure Security Groups 

o This setting is already pre-populated with a default security group for 
connecting via DCV. We’ll leave the ports alone and add the other required 
security groups later. 

o Leave the setting to Create a new security group 

o Change the Security group name to My-Studio-NICE-DCV-SG 

o Leave the Description as is 

o You will see warnings at the bottom of the screen about not being able to 
connect to the instance and recommending limiting access to known IP 
addresses.   

 We’ll be adding another security group to this instance later that will 
allow you to connect to it. 

⚠ Note: As in earlier tutorials, we are initially opening up this security group to 
inbound traffic from any IP address.  However, if you limited your source IP 
addresses during your Studio in the Cloud setup, you’ll want to do the same 
here. 
 
And if you will be accessing your instances over the public Internet, then after 
initial testing we recommend that you look into an AWS Direct 
Connect connection and/or VPN so that your connection will be private and 
secure.  You may use third party VPN software, but AWS also provides a robust 
set of VPN solutions called AWS VPN.  More information about how to connect 
to your VPC using VPN can be found here. 

o Click Review and Launch 

• Click Launch to launch your instance 

https://aws.amazon.com/directconnect/
https://aws.amazon.com/directconnect/
https://aws.amazon.com/vpn/
https://docs.aws.amazon.com/vpc/latest/userguide/vpn-connections.html


• Choose the key pair that you created when you originally set up your Studio in the Cloud 
and then click Launch Instances. If you don’t remember the name of the key pair you 
created, you can find it at the bottom of the Tutorial 1 section of the Important 
Information Cheat Sheet. 

• Once your instance has started launching, you’ll receive a Launch Status page. 

 
 

• On this page is a link to Usage Instructions that will tell you how to get started with 
NICE DCV. Click on View Usage Instructions. Feel free to read through the instructions to 
get an idea of what we’re going to next.  Don’t worry, we’re going to step you through 
everything below to ensure your instance is ready to use. 

Check Security Group 
In order to connect with DCV, you need to make sure the instance security groups allow inbound 
traffic to TCP port 8443. Luckily, the default security group allows for that port! However, we will 
need to add two additional security groups to allow us to connect to the instance and open the 
ports needed for Deadline so that it can be used as a Render Scheduler. 

• Go to Services→ EC2 and click on Running Instances to see a list of your running 
instances. 

• Select Render Scheduler - Linux 

• Choose Actions → Networking → Change Security Groups 

• Add My-Studio-Deadline-SG so you can open all the required deadline ports. 

• Add My-Studio-SSH-SG so you can connect to the instance via SSH. 



 
 

• Click Assign Security Groups 

Make Sure the Instance Can Access the License File 
In order to get access to the DCV license file, your instance IAM profile must have access to the 
Internet and be able access the required S3 Endpoint. The usage instructions for the NICE DCV 
AMI have documentation on how to set that up, but we’ll walk you through what you need to 
check below.  If you’d like to look at the official instructions for reference, you can find them 
here: https://docs.aws.amazon.com/dcv/latest/adminguide/setting-up-license.html.  
 
Let’s check if our current setup has access or not. Essentially, the documentation wants you to 
give the instance these permissions: 
 

 

Permissions – Note: <shift>+click on the image to open the text in a new tab. 

What that’s saying is that we want to allow the instance to be able to get an s3 Object from a 
specific resource - in this case a specific DCV license. 
 

https://docs.aws.amazon.com/dcv/latest/adminguide/setting-up-license.html
https://studio-in-the-cloud-tutorials.s3-us-west-1.amazonaws.com/tutorial-9/snippets/Make-sure-instance-can-access-license-file.txt


Let’s look at our current instance and see if we already have permissions that match this. 

• Back in the list of Running Instances, select your Render Scheduler - Linux instance. 

• In the Description tab on the bottom of the page, find IAM Role. 

• Click on EC2DomainJoin 

o This will take you to a summary of the IAM policies attached to your instance. 

 
 

o Click on AmazonS3ReadOnlyAccess 

o Click on the JSON button to see what the json definition looks like. 

AmasonS3ReadOnlyAccess JSON settings 

o As you can see from the Actions listed, we have permission for all actions that 
start with “s3:Get*”, and the DCV docs say we need permission for 
“s3:GetObject”. Theoretically, we should already have the permission we need, 
so there’s nothing additional we need to do here.  

Connect to the Render Scheduler - Linux Instance with SSH 
 
Now it’s time to connect to the remote machine via ssh and get it ready to connect via DCV. This 



process will seem very similar to you if you remember how we set up the Linux worker instances 
in Tutorial 6: Setting Up a Linux Farm Worker and Spot Fleet Request. 

• Go to Services → EC2 

• Click on Running Instances to see your list of running instances. 

• Check that your Render Scheduler - Linux instance is running and has passed 2/2 checks, 
then Select it. 

• Click Connect 

• Choose EC2 Instance Connect 

• Change the User name to ec2-user 

 
 

• Click Connect 

• A window will open with access to your instance.  Note: The brower-based SSH 
connection will automatically timeout after a few minutes of inactivity and the window 
will become unresponsive.  If that happens to you, please close the connection window 
and open a new one. 

• Run the following command to update the install.  

sudo yum -y --skip-broken update 

o Note: we’re passing the —skip-broken flag because as of the time of publication, 
there are a few issues with running the update. This flag will ignore the broken 
items and update everything else. 

https://studio-in-the-cloud-tutorials.s3-us-west-1.amazonaws.com/tutorial-6/Tutorial+6+-+Setting+Up+a+Linux+Farm+Worker+and+Spot+Fleet+Request.pdf


Set the Password for ec2-user 
One difference between the Linux-based Render Scheduler and the Windows one is that your 
login will be different. For Linux, we’ll be using the user ec2-user instead of Administrator. Thus, 
we need to create a password for this account. 

• Run the passwd command: 

sudo passwd ec2-user 

• Enter a password for ec2-user that you can remember 

Create a DCV Session 
Now it’s time to prepare your instance to be connected to. To do this, you’ll need to create a 
“session”: 

• Type the following command to create a session 

dcv create-session render-scheduler 

o Note: you can name your session whatever you wish. In this case, we’re naming 
it render-scheduler so we know what this session will be used for. 

• If you’d like more information on managing NICE DCV sessions, please refer to this 
documentation: Managing NICE DCV Sessions 

Connect to Your DCV Session 

• Back in the AWS Console, select your Render Scheduler - Linux instance from the list 

• In the Description tab below, copy the IPv4 Public IP Address. 

 
 

• Run the DCV Client on your local computer 

• Paste the Public IP Address that you copied above into the Hostname/IP Address field. 

https://docs.aws.amazon.com/dcv/latest/adminguide/managing-sessions.html


 
 

• Click Connect 

• When it pops up a warning about the connection not being secure, click 
on Trust (or Proceed if on MacOS) 

• Enter your Username as ec2-user, and Password with the password you set earlier. 

 

 

• Click Login 

• You are now connected to your Linux instance via the DCV Client! 



 
 

Make Sure DCV Always Runs 
 
In this example we manually created a session in order to connect to DCV. For the purpose of our 
Studio in the Cloud, we would rather the DCV service started automatically, ensuring we can 
start and stop the machine and still connect via DCV. 

Enable the DCV Service 

• Load a terminal in the DCV Session by going to Applications → Favorites → Terminal 

• Execute the following code to make sure the DCV Service starts automatically. 

sudo systemctl enable dcvserver 

o Note: Pasting with <ctrl>+v does not work with the Terminal app on your Linux 
instance, but you can right-click and select “Paste” instead.  

Create A Script To Start The Session 
Next, we’ll need to ensure that the session starts automatically when our instance restarts. To do 
this we’re going to create our own service similar to the one we enabled above, except it will be 
our own code that gets run every time the system starts! 
 
To do this, we’ll first create a bash script that will start our session for us. If you’re not 
comfortable editing text with vi, you may want to download a more visual text editor. It’s 
relatively easy to install gedit on your instance, so if you’d like to you can do that now. 
 



sudo yum -y install gedit 

• Now from a shell, create a file called render-scheduler.sh with either gedit or vi.  If you 
need a refresher on vi commands, please see this webpage: Vi Cheat Sheet.  gedit is a 
GUI-based editor, so it may be more intuitive to use if you’re not familiar with vi. 

o If you're using vi: 

sudo vi /usr/bin/render-scheduler.sh 

o If you're using gedit: 

sudo gedit /usr/bin/render-scheduler.sh 

•  Enter the following code into the text editor and save it. 

render-scheduler.sh – Note: <shift>+click on the image to open the text in a new tab. 

• Save and quit. Once the file is saved, you’ll need to make it executable. 

sudo chmod +x /usr/bin/render-scheduler.sh 

• This file will start the render-scheduler dcv session whenever it’s executed. Let’s give it a 
try: 

/usr/bin/render-scheduler.sh 

• Did you receive an error stating it had trouble creating the session? If render-scheduler 
already exists, the bash script will exit with an error, not giving you the wonderful 
success message. Don’t worry, this is an easy fix! 

• Edit the file again using either vi or gedit. 

o If you're using vi: 

sudo vi /usr/bin/render-scheduler.sh 

o If you're using gedit: 

sudo gedit /usr/bin/render-scheduler.sh 

https://ryanstutorials.net/linuxtutorial/cheatsheetvi.php
https://studio-in-the-cloud-tutorials.s3-us-west-1.amazonaws.com/tutorial-9/snippets/render-scheduler.txt


• Add “|| true“ after the line where we create the session. 

sudo dcv create-session --owner ec2-user --user ec2-user render-scheduler || true 

o Note: This will still return the error, but it won’t stop the script so any commands 
after the error will still execute properly! 

• Save the file and quit and run it again: 

/usr/bin/render-scheduler.sh 

• You should now see the success message, even if it returned an error! 

Create the Service to Run the Script 
The next step is to create the service that will execute this file every time the instance is started. 
The nice thing about working this way is that we can modify this file to add more options any 
time we want and it will be executed again whenever the system is restarted. It’s similar to the 
user data settings we have on the instance, but in this case it's much more controllable. 

• Create the service file using either gedit or vi: 

o If you're using vi: 

sudo vi /etc/systemd/system/render-scheduler.service 

o If you're using gedit: 

sudo gedit /etc/systemd/system/render-scheduler.service 

• Enter the following code into the text editor and save it. 

render-scheduler.service – Note: <shift>+click on the image to open the text in a new tab. 

 

o This is a relatively simple service that will simply execute the file we created 
earlier (/usr/bin/render-scheduler.sh). 

o The key here is the line ExecStart that tells the service what script to run. 

• Quit the editor after the file is saved. 

• Next we’ll start the service 

https://studio-in-the-cloud-tutorials.s3-us-west-1.amazonaws.com/tutorial-9/snippets/render-scheduler.service.txt


sudo systemctl start render-scheduler 

• And then make sure will start automatically on boot. 

sudo systemctl enable render-scheduler 

Check that the Service Is Working 
If this has all been set up correctly, you should be able to stop your instance, start it again, and 
then connect to the new IP address using the DCV client, without having to manually start the 
session. 

• Disconnect your session by clicking on the drop down menu in the upper right corner of 
the DCV client window or by closing the client altogether 

• Go EC2 → Instances 

• Select the Render Scheduler - Linux instance 

• Choose Actions → Instance State → Stop 

• After the instance has stopped, choose Actions → Instance State → Start 

• Once the instance has spun up and is ready to use, copy the public IP address. 

o Note: The public IP address will change every time the instance stops and then 
starts. If you want to maintain the same public IP address, this is possible 
through something called an Elastic IP Address. 

• Open the DCV Client and connect to the new public IP address  

• Log in using ec2-user and password. 

• If you were able to start a session - congratulations! You’ve successfully created a linux 
service to automatically create a DCV Session! We’ll be working with this service a bit 
later to do more magic as well... but in the meantime... 

o Note: If you had trouble and weren’t able to connect, feel free to connect to the 
instance using the ssh techniques in the beginning of the tutorial, and make 
sure all your code was entered correctly. 



 
 

Join Active Directory 

• To join Active Directory from your Linux Render Scheduler run these commands. Make 
sure you update the text to match the name of your Active Directory.  You’ll be replacing 
the two instances of “mystudio.com” with your Active Directory’s DNS Name. 

• Load a terminal in the DCV Session by going to Applications → Favorites → Terminal 

• Enter the commands below, making sure to swap out “mystudio.com” for your Active 
Directory’s DNS name, if different. You can find the DNS name under Tutorial 2 on the 
cheat sheet: 

• First install the specific tools to make it possible to connect to Active Directory. 

sudo yum -y install sssd realmd krb5-workstation samba-common-tools 

• Then join Active Directory 

sudo realm join -U Admin@mystudio.com mystudio.com --verbose 

• You should receive a message that says: Successfully discovered: mystudio.com (or your 
DNS name, if different) 



• Type in the password for your Active Directory and you will see a message that 
says: Successfully enrolled machine in realm 

• In preparation for the next step, it is recommended to perform a mkdir in /mnt/ to 
create a directory for the FSx mount. 

sudo mkdir /mnt/studio 

Mount FSx File System 

• First run this command to install some utilities: 

sudo yum -y install cifs-utils 

• Next run the command below and enter the Active Directory Admin password when 
prompted.  Make sure to replace MYSTUDIO with your Active Directory’s DNS Name and 
type it in all capital letters. 

kinit Admin@MYSTUDIO.COM 

• Finally, run the command below to mount your FSx drive.  Again, make sure you update 
the green text to match your Active Directory DNS Name and the FSx DNS Name.  You 
can find this information under Tutorial 2 and Tutorial 3 on your cheat sheet. 

• Note: Please check the direction of the slashes when you enter the FSx DNS Name since 
they are “\” when on Windows, but “/” when on Linux, as we are here. 

sudo mount -t cifs -o user=Admin@MYSTUDIO.COM,cruid=$(id -u),uid=$(id -
u),sec=krb5 //fs-0c0b4fab1db1b9a0e.mystudio.com/share /mnt/studio -o 
vers=3.0 

 
Again, please note which text is capitalized. These commands ARE case sensitive. 

• To test and see if it mounted correctly, do an ls of the directory 

ls /mnt/studio 

• If you see a few folders returning back, then you’ve connected correctly! 

Modify render-scheduler.sh to Mount Active Directory 
Now that we have Active Directory mounted in this session, we’ll want to modify our render-
scheduler service to always mount Active Directory when we’re starting and stopping our 
instance.  
 

• Edit the render-sceduler.sh file with your favorite editor (vi or gedit) 

o If you're using vi: 

sudo vi /usr/bin/render-scheduler.sh 



o If you're using gedit: 

sudo gedit /usr/bin/render-scheduler.sh 

• Add the lines about connecting to Active Directory after the previous lines you created. 
The final script should look like the following. Don’t forget to modify the region, drive, 
and studio In lines 15, 16, and 17 based on your own settings. 

render-scheduler.sh with added Active Directory code. 

Note: <shift>+click on the image to open the text in a new tab. 

• IMPORTANT: You will need to update the items highlighted below in yellow with specific 
information for your studio 

 

• The next time you stop and start your instance, it should automatically create a session 
and mount active directory for you. Feel free to test if you want, or continue on and start 
installing Deadline. 

Install Deadline Tools 

Install Deadline Repository 
 
First we’ll install the Deadline Repository. Luckily, you should have all the installer files in your 
/mnt/studio/installers/thinkbox folder from when you set up Studio in the Cloud initially. 

https://studio-in-the-cloud-tutorials.s3-us-west-1.amazonaws.com/tutorial-9/snippets/render-scheduler-withActiveDirectory.txt


• Load a Terminal in the DCV Session by going to Applications → Favorites → Terminal 

• Run the command below to go to the installers location for thinkbox 

cd /mnt/studio/installers/thinkbox 

• You should have the DeadlineRepository and DeadlineClient installers for linux 
there.  Run the command below. Note: You may need to replace the version number 
(e.g., 10.1.3.6) with number of the version that you are using: 

sudo ./DeadlineRepository-10.1.3.6-linux-x64-installer.run 

 
If you don’t have the installers, please follow the instructions from Tutorial 4: Building a Render 
Scheduler with AWS Thinkbox Deadline and then run the installer. 
 
The steps should be very similar to the ones you followed initially for Windows. The only 
difference is that we’re going to create a new location to install the certificates to so we don’t 
overwrite the old ones. 

• Click Forward when the Welcome message appears. 

• Accept the license agreement. 

• Leave the Repository Directory at the default. 

• Select Install a new MongoDB database on this machine. 

• Accept the new limit 

• Click Forward when it asks to download Mongo DB 

• Leave all the MongoDB installation options at the default 

• We’re going to change the location of the Certificate Directory 

o Click the File Browse button next to the Certificate Directory text field 

o Navigate to /mnt/studio/app_env/thinkbox 

o Click New Folder  

o Name the new folder DeadlineCertificates_linux 

o Double-click on the new folder 

o Click OK 

o Click Forward 

• Click Forward 

• Wait for it to install the Deadline Repository 

• Click Finish when it’s done. 

https://studio-in-the-cloud-tutorials.s3-us-west-1.amazonaws.com/tutorial-4/Tutorial+4+-+Building+a+Render+Scheduler+with+AWS+Thinkbox+Deadline.pdf#page=11
https://studio-in-the-cloud-tutorials.s3-us-west-1.amazonaws.com/tutorial-4/Tutorial+4+-+Building+a+Render+Scheduler+with+AWS+Thinkbox+Deadline.pdf#page=11


Install Deadline Client 
 
Now we’ll install the Deadline Client. Again, it’s very similar to what we’ve done in the past. 

• Install lsb 

sudo yum -y install lsb 

• Change directories so you are inside installers/thinkbox. 

cd /mnt/studio/installers/thinkbox 

 

• To install the Deadline Client run this command.  Note: Again, the Deadline Client may 
be a different version what what is specified here. Please adjust as needed. 

sudo ./DeadlineClient-10.1.3.6-linux-x64-installer.run 

• Give these answers to the prompts: 

o Click Forward when the Welcome message appears 

o Accept the License Agreement 

o Leave Installation Directory at the default and click Forward 

o Select Remote Connection Server and click Forward 

o Leave Connection Type as Repository and click Forward 

o Leave the Repository Directory as default and click Forward 

o Set the Database SSL 
Certificate to /mnt/studio/app_env/thinkbox/DeadlineCertificates_linux/certs/D
eadline10Client.pfx and click Forward 

o Set License Mode to Usage Based and click Forward 

o Set Launch Worker When Launcher Starts and click Forward 

o Leave the Remote Connection Server Setup options at the default and click 
Forward 

o Make sure Generate New Certificates is enabled and click Forward 

o Set the Output Directory to the same directory you put the Deadline10Client.pfx 
certificate: /mnt/studio/app_env/thinkbox/DeadlineCertificates_linux/certs and 
click Forward 

o Click Forward again to continue the install 

o Click Finish when you’re done. 

Launch Deadline Monitor, Deadline RCS, and Deadline Pulse 

• Enter the following command to load the monitor 



/opt/Thinkbox/Deadline10/bin/deadlinemonitor & 

• This will launch the monitor. The first time it runs, you’ll need to accept the creation of 
the new user ec2_user. 

• In the Terminal window, hit <enter> to get the command prompt back, then enter the 
following commands one a t a time to load Deadline RCS, Deadline Pulse, and Deadline 
Worker so you can see that the monitor is working: 

/opt/Thinkbox/Deadline10/bin/deadlineworker & 

 

/opt/Thinkbox/Deadline10/bin/deadlinepulse & 

 

/opt/Thinkbox/Deadline10/bin/deadlinercs & 

• You can minimize all the other applications besides the monitor (including the Terminal 
window). 

 
 

Set Mapped Paths 
Because we will be using Linux workers for rendering, we need to create some mapped pathing 
to make sure our file paths convert from Windows to Linux correctly. For example, a file located 



at Z:\project\myshow\shot_01.ma on your Windows machine will need to be mapped to 
/mnt/studio/project/myshow/shot_01.ma. Deadline can do this automatically when it’s set up 
correctly. 

• In the Deadline Monitor, click on Tools 

• Choose Tools → Super User Mode 

• Choose Tools → Configure Repository Options 

• Click on Mapped Paths 

• Under Global Rules click Add 

o For Replace Path, enter Z: 

o For Windows Path, enter Z: 

o For Linux Path, enter /mnt/studio 

• Click OK 

• Click OK again to close the window 

Set Up Render Groups 
Now we want to create a render group. You can create multiple groups if you want, but for our 
case a single one will be fine. 

• Go Tools → Manage Groups... 

• Click New 

• For Group name enter: linux_worker 

• Click OK 

• Click OK again 

Test Your Setup 
To test the setup, we’re going to do a quick batch render test. We’ll be creating a simple python 
file that will accept the frame number and print an to the render logs.  

• Open a new Terminal by going to Applications → Favorites → Terminal 

• In the terminal, create a python file called test_render.py with either gedit or vi: 

o If you're using vi: 

vi ~/test_render.py 

o If you're using gedit: 

gedit ~/test_render.py 



• Enter the following text: 

test_render.py – Note: <shift>+click on the image to open the text in a new tab. 

• Save your file and quit. 

• Inside the Deadline Monitor, go Submit → Miscellaneous → Python 

• Under Job Name enter Test Render 

• Set the Frame List to 1-10 

• Set the Python Script File to /home/ec2-user/test_render.py 

• Set Arguments to <STARTFRAME> by clicking the Start Frame Tag button 

• Make sure Python Version is 2.7 

• Click Submit 

• Once the job has started picking up, you should be able to track your render in the 
monitor. Open a task and look at the log to see if it worked correctly. 

https://studio-in-the-cloud-tutorials.s3-us-west-1.amazonaws.com/tutorial-9/snippets/test_render.txt


 
 

Make Sure Deadline Monitor, Deadline RCS & Deadline Pulse Always Run When Logging In 
In order for the Render Scheduler to work effectively, it’s important for these three tools to be 
running. In order to make sure they run every time you log into the Render Scheduler as ec2-
user, we can set them up to start automatically. This way you just need to login as ec2-user and 
the Render Scheduler will be ready to go. 

• Open up the Terminal and type 

• gnome-session-properties 

o This will allow you to add additional startup programs that will run every time 
you log in. 

• Add Deadline Monitor by clicking Add 

o For Name enter Deadline Monitor 

o For Command enter /opt/Thinkbox/Deadline10/bin/deadlinemonitor 

o For Comment enter Launches Deadline Monitor 



 
 

o Click Add 

• Add Deadline Pulse by clicking Add 

o For Name enter Deadline Pulse 

o For Command enter /opt/Thinkbox/Deadline10/bin/deadlinepulse 

o For Comment enter Launches Deadline Pulse 

o Click Add 

• Add Deadline RCS by clicking Add 

o For Name enter Deadline RCS 

o For Command enter /opt/Thinkbox/Deadline10/bin/deadlinercs 

o For Comment enter Launches Deadline RCS 

o Click Add 



 

• Click Close 

• You now have all three Deadline apps ready to load when you log in as ec2-user after a 
restart. Congratulations! 

Update Linux Worker 
Now that our Render Scheduler is up and running on a Linux instance, we will need to update 
our workers to point to this new instance. This is a relatively quick fix, but we will need to update 
our AMI to point to the new Render Scheduler. 

Launch a Worker 

• Go to Services → EC2 

• Click on Launch Templates 

• Select the My-Studio-Worker-LT 

• Choose Actions → Launch Instance From Template 



• Under Source template version, make sure the most recent version is selected 

• Under Instance tags, change the name to Worker_Linux_new 

o Note: We’re changing the name here so that it’s easy to identify our new Linux 
worker in case you still have any old workers around in your instance list from 
completing the previous tutorials.  You’ll definitely want to launch a new Linux 
worker from the template, rather than trying to reuse an old one, just to ensure 
that you have all the correct user data and other settings. 

• Scroll down and click Launch instance from template 

Modify Worker deadline.ini File 

• Once the worker is running and ready to connect, Select it and choose Connect 

• Select EC2 Instance Connect and username ec2-user just like you did before with the 
Linux Render Scheduler. 

• Stop the deadlineworker by typing 

sudo /opt/Thinkbox/Deadline10/bin/deadlineworker -shutdown 

• When the shutdown is complete, modify the deadline.ini file. Again, if you need a 
refresher on vi commands, please see this webpage: Vi Cheat Sheet.  

sudo vi /var/lib/Thinkbox/Deadline10/deadline.ini 

• You’re going to be modifying the two lines that have ProxyRoot which point to the 
IP address for the Render Scheduler, and change the line for the Certificate. 

• First go and get the private IP address for the new Render Scheduler - Linux instance by 
selecting it in the EC2 Instances console and looking in the Description Tab. 

• Find a line that looks something like (note: your ip address will be different): 

ProxyRoot=10.0.0.219:4433 

and replace it with the private IP address for your new Linux Render Scheduler.  Note: 
Make sure to use the private IP address and not the public IP address that you used 
when connecting with DCV 

ProxyRoot=10.0.0.153:4433 

• Now do the same for the line that has ProxyRoot0 

ProxyRoot0=10.0.0.219:4433 

becomes 

ProxyRoot0=10.0.0.153:4433 

https://ryanstutorials.net/linuxtutorial/cheatsheetvi.php


• Next change the path in ProxySSLCertificate to point to the new 
DeadlineCertificates_linux path 

ProxySSLCertificate=/mnt/studio/app_env/thinkbox/DeadlineCertificates/Dea
dline10RemoteClient.pfx 

changes to 

ProxySSLCertificate=/mnt/studio/app_env/thinkbox/DeadlineCertificates_lin
ux/certs/Deadline10RemoteClient.pfx 

• Now quit and save by typing :wq 

• Restart the deadlineworker to get these new changes  

sudo /opt/Thinkbox/Deadline10/bin/deadlineworker -nogui 

• If you’ve set the values correctly, when you go check your Deadline Monitor in the new 
Linux Render Scheduler, your worker will now show up! 

 
 

Create a New AMI for Your Worker 

• Shut down your new Linux worker instance and create an Image of it. 

o Go to Services→EC2 

o Click on Instances 

o Right click on your Worker-Linux instance and choose Instance State→Stop 

• Once stopped, right click on it again and choose Image→Create Image 

• Enter a name for your image (e.g., My-Studio-Worker-v02-AMI) and a description for 
your image 

• Check that the size of your volume is set to 300 GiB 

• Click Create Image 

• In the navigation pane on the left, under Images, select AMIs. 

• Find the name of your Linux Worker AMI in the list and note the AMI ID as well.  Write 
down both of these in your cheat sheet. Because not everyone will be adding a Linux Render 
Scheduler, there’s not an existing section on the sheet to enter this information, but you 
can use the Notes section at the bottom to enter it on your own. 

• Add appropriate Name and Studio tags. 

• Wait a few minutes while the AMI is pending. 



Modify Worker Launch Template 

• Now we need to update the Launch Template to use this new AMI. 

• Go to Services → EC2 

• Click on Launch Templates 

• Choose the My-Studio-Worker-LT 

• Choose Actions → Modify Template 

• Update the description to something like “Updated worker to point to Render Scheduler 
- Linux”  

• Update the Amazon Machine Image to point to the new AMI (My-Studio-Worker-v02-
AMI) 

o If you see a popup that says some of your settings will be changed, click Confirm 
Changes 

• Under Storage (volumes) change Volume type to Don't include in template. 

• Open Advanced Details 

• Look at the EBS-optimized instance setting.  Make sure it is set to Don’t include in 
launch template.  Even if it is already set to that, open the drop down menu and select it 
again.   

• Scroll down and click Create template version 

• Go back to your list of Launch Templates 

• Choose My-Studio-Worker-LT 

• Notice that the Default Version is 1, but the Latest Version is 2. 

• Choose Actions→ Set default version 

• Set the version to 2 and click Set as default version 

• Now the latest version of the template will use version 2. 

Creating Your Render Fleet 
To allow Deadline to automatically spin up Linux workers for us we need to create a spot 
request. 

• In the EC2 Console, click on Spot Requests on the left hand bar  

• Click Request Spot Instances 

• Switch to Flexible workloads 



 
 

• Select your updated Linux Worker Launch Template (e.g., My-Studio-Worker_LT) in 
the Launch Template bar, and make sure it is the correct version. 

 
 

• Most of the settings can be left as default. 

• Scroll down and select your Total Target Capacity. Set it to whatever you want - 1, 5, 10, 
etc.. 

• Select the checkbox next to Maintain target capacity 

• Once you are ready to go DO NOT CLICK the Launch button. 

• Scroll down to the bottom and look in the left corner.  

• Click on JSON config and this will download a file called config.json. 

o We will modify this configuration file to tell Deadline what instances to launch 
when someone submits a render for a given group. 

Attaching Render Fleet 

• Switch over to your Render Scheduler - Linux instance in the DCV client 

• Go Tools→ Configure Events 



o If you don’t see Configure Events, make sure you Enable Super User mode in the 
Tools menu 

• Click on Spot 

o Make sure to set the State to Global Enabled 

o Enter the access key ID and secret access key for your IAM user.  If you created a 
new IAM user in Tutorial 1 you can find the access key ID and secret access key in 
the credentials.csv you downloaded at that time.  You can find the location of 
your credentials.csv on the cheat sheet. 

o If you didn’t setup the IAM user for your account or do not have the 
credentials.csv handy, you can create a new access key using these 
directions: Where’s My Secret Access Key? 

o Make sure the Region is set correctly 

o Inside the Spot Fleet Request Configurations you’ll paste the contents of 
your config.json, but be sure to add  it with the following line in front of it: 

{"linux_worker": 

o And this line after: 

} 

o The whole thing should look something like: 

https://aws.amazon.com/blogs/security/wheres-my-secret-access-key/


Example config.json 

• Click OK 

• Run House Cleaning by going to Tools → Perform House Cleaning 

o This will help force the changes you’ve made to the Spot Event plugin get 
recognized. 

Test the Spot Event Plugin 
 
Now it's time to test the spot event plugin. To do this, we'll move the test_render.py script to a 
location that one of the workers can find it, and then run another test. This time we'll also 
specify the linux_worker group to see if we can get some workers to spin up. 

• Open up a Terminal on your Linux Render Scheduler 

• Move the test_render.py file to /mnt/studio 

sudo mv ~/test_render.py /mnt/studio/test_render.py 



• In Deadline Monitor choose Submit → Miscellaneous → Python 

• Set the Job Name to Test Spot 

• Set Group to linux_worker 

• Set the Frame List to 1-10 

• Set Python Script File to /mnt/studio/test_render.py 

• Click Submit 

• Now wait a few minutes for the Spot Event Plugin to start working. 

• If you want to check on the Spot request, go to Services→ EC2 and then click on Spot 
Requests. A Fleet Request should appear, launching render workers. 

o Note: It can take 5 minutes for the spot event plugin to start for the first time. If 
you don’t see any requests and you are confident that it should be working, just 
be patient. It might take a while. 

 
 

• If the Spot request is not there double check that you set the correct region 

• If the Spot request is there, but no workers are spinning up, you can check for errors by 
clicking pending fulfillment on the Spot request status, and going to the History tab. It 
should give you a good idea of any issues you may encounter.  

 
 

• Once the status of the spot request has changed from pending fullfillment to fullfilled, 
you should see a new worker pop up in the Worker list in the Deadline Monitor and your 
frames should start rendering. 



 
 

Update Workstation 
We’re almost done! The next step is to update our Workstation AMI to point to the new Render 
Scheduler just like we did with the workers. 

Launch a Workstation 

• Go to Services → EC2 

• Click on Launch Templates 

• Select the My-Studio-Workstation-LT 

• Choose Actions → Launch Instance From Template 

• Under Instance tags, change the name to Workstation_Win_new 

o Note: As with the Linux worker, we’re adding “_new” to the end of the name for 
this instance so that we can tell it apart from any other Windows workstations 
we might currently have in our instance list. 

• Scroll down and click Launch instance from template 

Connect to the Studio FSx Drive 

• Once the workstation is running and ready to connect, select it and choose Connect 



• Log in as Administrator (NOT mystudio/Admin) because we’ll be modifying the ini file 
and running SysPrep. 

• Open a File Explorer window. 

• From the navigation pane, right-click on This PC and choose Map Network Drive... 

• Choose a drive letter of your choice for Drive (e.g., Z:) 

• Enter the full CNAME Alias for your file share that you noted above for Folder.  

o e.g., \\studio.mystudio.com\share\ 

o click Finish 

• Use your Active Directory Admin login credentials. For example: 

o Username: Admin 

o Password: Your Admin Password 

Modify Workstation Repository 

• Open the Monitor by going Start → Thinkbox → Deadline Monitor 

• When it opens, it will be pointing at the old repository. 

• Choose File → Change Repository 

 
 

• Modify the Remote Server to the new IP Address  



• Modify the Client Certificate to point to the new path (e.g., 
Z:/app_env/thinkbox/DeadlineCertificates_linux/certs/Deadline10RemoteClient.pfx) 

 

 

• Click OK 

• When it asks if you want to Change the repository, check Save Answer and click Yes 

• After a few seconds, the repo will shift to the new respository! 



 
 

• Quit out of Deadline Monitor 

Preparing Your Instance to Create a New AMI 
Now that you’ve updated your Deadline settings, we’ll need to make a new AMI with these 
settings, and update our Launch Template. 

• Disconnect from your FSx Drive (Z:)  

o Open the File Explorer 

o Under This PC on the left, click on the Z: drive with the Right Mouse Button and 
choose Disconnect 



 
 

• Go to the start menu, type Ec2LaunchSettings and launch it 

• Make sure Set Computer Name is selected 

o This will ensure each instance you create has a unique name. 

• Check that Administrator Password is set to Specify and input the Administrator 
Password for your Active Directyory(e.g. password for mystudio\Admin) 

• Select Run EC2Launch on every boot 

• Click Shutdown with Sysprep 

 
 



• Click Yes 

• This will shut down your instance after a few processes run. It can take a few minutes, so 
feel free to grab a coffee (or tea). 

Create Workstation AMI 

• Navigate back to the EC2 Dashboard and find the Workstation that has just been shut 
down, if it is not completely stopped yet, wait for that process to finish 



 
 

• Right-click on the instance and choose Image → Create Image 

• Give it an appropriate name (e.g., My-Studio-Workstation-v02-AMI)  Please also enter the 
AMI name in the Notes section on your cheat sheet. 

• Give your workstation AMI a description if you want. 

• Increase its storage if necessary. 

 
 

• Click Create Image 

• AMI creation can also take 5 to 10 minutes to complete. How about more coffee? 

o To see if your AMI is ready click on AMIs in the left panel. The AMI will need to 
finish creating before you can create a Launch Template with it. 

o While you’re waiting, you can also add Tags to your AMI. Again, we recommend 
creating at least a Studio tag and Name tag. 

o Now is a good time to note the AMI ID in the Notes section of the cheat sheet.  You 
can find the ID by selecting the AMI from the list and looking at the top left of the 
Details tab. 

Modify Workstation  Launch Template 

• Now we need to update the Launch Template to use this new AMI. 

• Go to Services → EC2 

• Click on Launch Templates 



• Choose the My-Studio-Workstation-LT 

• Choose Actions → Modify Template 

• Update the description to something like “Updated workstation to point to Render 
Scheduler - Linux”  

• Update the Amazon Machine Image to point to the new AMI (My-Studio-Workstation-
v02-AMI) 

• Scroll down and click Create template version 

• Go back to your list of Launch Templates 

• Choose My-Studio-Workstation-LT 

• Notice that the Default Version is 1, but the Latest Version is 2. 

• Choose Actions→ Set Default Version 

• Set the Template version version to 2 and click Set as default version 

• Now the latest version of the template will use version 2. 

Test Workstation 

• Use the new Launch Template to launch a new Workstation. 

• Once it's up, connect and log in as one of your user accounts (e.g., mystudio\jason) 

• Make sure that when you run the Deadline Monitor you’re connecting to the new Render 
Scheduler - Linux instance.  Note: You can tell that you’re connected to the your new 
Render Scheduler by looking at list of jobs.  If you see your “Test Spot” job from earlier, 
then you should be good to go. 

• Go ahead and launch a new render from blender and make sure it works correctly. If all 
goes as planned - you’re now using your new Linux-based Render Scheduler! 

Shut Down Old Render Scheduler 

• You can go ahead and Terminate your old Render Scheduler if you aren’t going to use it 
anymore. 

 

Appendix 

List of Studio in the Cloud Tutorials 
 
Tutorial 1: Getting Started with AWS Virtual Workstations  
Tutorial 2: Creating a VPC and Active Directory for Your Studio 
Tutorial 3: Setting Up an FSx File System and User Accounts 
Tutorial 4: Building a Render Scheduler with AWS Thinkbox Deadline 
Tutorial 5: Installing Applications and Creating a Workstation AMI 

https://studio-in-the-cloud-tutorials.s3-us-west-1.amazonaws.com/tutorial-1/Tutorial+1-+Getting+Started+with+AWS+Virtual+Workstations.pdf
https://studio-in-the-cloud-tutorials.s3-us-west-1.amazonaws.com/tutorial-2/Tutorial+2+-+Creating+a+VPC+and+Active+Directory+for+Your+Studio.pdf
https://studio-in-the-cloud-tutorials.s3-us-west-1.amazonaws.com/tutorial-3/Tutorial+3+-+Setting+Up+an+FSx+File+System+and+User+Accounts.pdf
https://studio-in-the-cloud-tutorials.s3-us-west-1.amazonaws.com/tutorial-4/Tutorial+4+-+Building+a+Render+Scheduler+with+AWS+Thinkbox+Deadline.pdf
https://studio-in-the-cloud-tutorials.s3-us-west-1.amazonaws.com/tutorial-5/Tutorial+5+-+Installing+Applications+and+Creating+a+Workstation+AMI.pdf


Tutorial 6: Setting Up a Linux Farm Worker and Spot Fleet Request 
Tutorial 7: Onboarding New Artists and Sample Workflow 
Tutorial 8: Add-On - Upgrading to Teradici for Desktop Streaming 
Tutorial 9: Add-On - Using a Linux Instance for a Render Scheduler - this page 

Links to AWS Documentation 

• NICE DCV Clients 

• AWS Direct Connect 

• AWS VPN 

• VPN Connections to AWS VPC 

•  Managing NICE DCV Sessions 

Links to Other Resources 

• Vi Cheat Sheet 

Downloads 

• Important Information Cheat Sheet 

 

https://studio-in-the-cloud-tutorials.s3-us-west-1.amazonaws.com/tutorial-6/Tutorial+6+-+Setting+Up+a+Linux+Farm+Worker+and+Spot+Fleet+Request.pdf
https://studio-in-the-cloud-tutorials.s3-us-west-1.amazonaws.com/tutorial-7/Tutorial+7+-+Onboarding+New+Artists+and+Sample+Workflow.pdf
https://studio-in-the-cloud-tutorials.s3-us-west-1.amazonaws.com/tutorial-8/Tutorial+8+-+Add+On+-+Upgrading+to+Teradici+for+Desktop+Streaming.pdf
https://docs.aws.amazon.com/dcv/latest/userguide/client.html
https://aws.amazon.com/directconnect/
https://aws.amazon.com/vpn/
https://docs.aws.amazon.com/vpc/latest/userguide/vpn-connections.html
https://docs.aws.amazon.com/dcv/latest/adminguide/managing-sessions.html
https://ryanstutorials.net/linuxtutorial/cheatsheetvi.php
https://studio-in-the-cloud-tutorials.s3-us-west-1.amazonaws.com/tutorial-1/Important-Information-Cheat-Sheet.pdf
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